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Tips from This Issue
Here is a digest of the tips in this issue of the Claris-
Works Journal. Details and step-by-step instructions
appear on the page indicated after each tip.

General Tips

1. If you increase ClarisWorks’ “Preferred Memory”
setting you will get better performance and fewer
“Insufficient memory” messages. (page 2)

2. You can control ClarisWorks’ default font and doc-
ument settings by creating a file named “Claris-
Works WP Options”. (page 3)

3. You can use text and graphic frames to simulate
removable Post-It notes. (page 6)

4. You can use commercially available “designer”
paper to add pizzazz to your documents. (page 8)

Database Tips

1. Display both layout and browse views whenever
you change a database layout. (page 4)

2. Pressing Option-minus automatically enters today’s
date or time into date and time fields. (page 4)

3. The easiest way to move a database label and its
associated field is to select both objects and use the
Arrow Keys. (page 14)

Spreadsheet Tips

1. Use ClarisWorks’ spreadsheet charting capabilities
whenever you need a chart or table in a document.
(page 4)

2. Use ClarisWorks’ Copy Table command when you
want to insert downloaded data into a spreadsheet.
(page 4)

3. Use ClarisWorks’ BEEP and ALERT functions to
automatically check all data entered into a spread-
sheet file. (page 5)

4. Use ClarisWorks’ Lock Titles command when you
want to lock the titles on your spreadsheet screen.
(page 5)

From the Editors
Welcome to this sample issue of the
ClarisWorks Journal, the popular
ClarisWorks newsletter from the Claris-
Works Users Group (C•WUG, pronounced
“SEE-wug”). We published this abbreviated
newsletter because we want you to know about
C•WUG, our independent association of more than
15,000 ClarisWorks users in the United States and 51
other countries. C•WUG has one goal – to enhance
your productivity with ClarisWorks.

C•WUG members receive these valuable services:

• Home or office delivery of a full year (ten issues) of
the ClarisWorks Journal. Each 24-page issue is
filled with hints, tips, news, and ideas that will
enhance your productivity with ClarisWorks.

• Unlimited ClarisWorks telephone support from
C•WUG’s 65 volunteer-consultants.

• Access to C•WUG’s ClarisWorks support site on
the World Wide Web and to the C•WUG areas on
America Online and CompuServe. These services
give you immediate access to C•WUG’s Claris-
Works templates, fonts, and graphics, and 24-hour-
a-day answers to your ClarisWorks questions.

• Access to C•WUG’s Public Domain Library with
more than 550 disks filled with ClarisWorks tem-
plates, graphics and ClarisWorks-compatible fonts
and utilities.

• Significant discounts on ClarisWorks-compatible
products and other special offers that we negotiate
for our members.

You’ll find more information about C•WUG and a
special discount membership offer in the brochure we
enclosed with this issue. We’re so sure you’ll like our
offerings that we maintain a “satisfaction guaranteed or
all your money back” policy for our members.

Give us a try – it’s risk free. We hope you’ll join
C•WUG and enjoy the ClarisWorks Journaland all
our other valuable member services.

(Continued on back cover)

Greetings

from C•W
UG!
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memory when you launch the program, which
should eliminate the “insufficient memory”
messages. Then close the dialog box and
launch ClarisWorks.

You can monitor the memory usage in your Macin-
tosh by returning to the Finder and selecting “About
this Macintosh” from the Apple Menu. Your system
will display the About this Macintosh Window in
Figure 2. The “Built-in Memory” value should cor-
respond to the amount of memory installed in your
computer. (One megabyte of memory is 1024K of
RAM. The computer in Figure 2 contains eight
megabytes (or 8,192K) of RAM.) You can use the size
of the largest unused block of memory to help you
determine the maximum amount of memory you can
make available to ClarisWorks on your computer.

The data to the right of “ClarisWorks 4.0” indicates
that the program captured 1400K of RAM. The solid
segment within the horizontal bar displays the pro-
portion of the 1400K currently used by the program
and your open ClarisWorks documents. ClarisWorks
will generate insufficient memory error messages
when the solid bar fills the rectangle no matter how
much unused memory you have in your computer.]■
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Managing the Memory in Your Mac
Dear C•WUG,

I have eight megabytes of memory in my Macin-
tosh, yet I get occasional messages indicating I
need more memory in my system. Don’t I have
enough memory to run ClarisWorks?

Jennifer Erb-Downward
Evanston, Illinois

[Ed: You have more than enough memory to run
ClarisWorks, Jennifer, but you probably never told
ClarisWorks to use that memory.

Memory management in a Macintosh is a two-part
process. First, you add the memory chips to your
computer (or use a software-based enhancement
that simulates more memory). Second, you must tell
your applications to “grab” more memory when
you launch the program. Unless you change Claris-
Works’ default settings, the program will only cap-
ture 1400K of RAM. That setting lets you run Claris-
Works on almost any Macintosh system but can
cause occasional “out of memory” messages even if
you have lots of memory installed in your computer.

You should change this setting if you have four
megabytes or more of RAM in your system. Follow
these steps:

1. Quit ClarisWorks and return to the Macintosh
Finder. (You cannot change the amount of mem-
ory used by an application with the program
running on your computer.)

2. Click once on the ClarisWorks application icon
and select “Get Info” from the File Menu to
display the ClarisWorks Info Dialog Box in
Figure 1.

The Memory Requirements section of the dialog
box tells ClarisWorks how much memory to reserve
when you launch the program. Figure 1 depicts the
default settings that tell ClarisWorks to capture and
run within only 1400K of memory, no matter how
much memory you have in your system. (The “Min-
imum size” setting tells ClarisWorks to launch even
if it can find only 1000K of available RAM.)

3. Change the “Preferred size” setting to at least
2000K. That tells ClarisWorks to capture more

Letters to C•WUG

Figure 1: ClarisWorks Info Dialog Box

Figure 2: About this Macintosh
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Turn back the clock for a moment,
back to the days of journeymen and
apprentices. It’s easy to picture an

apprentice watching the journeyman and
trying each new technique demonstrated
by the master.

With time, the apprentice becomes a mas-
ter himself, embellishes what he learned
from his teacher, and passes his knowledge
to the next generation of artisans.

So it should be with ClarisWorks. Spend
a few minutes with a master and you will
learn more about the program than you
can from the best of books. Ask ques-
tions. Probe. Stop his work in mid-
stream. And be prepared to remember all
the techniques before you.

That is how we prepared this article. We
watched, asked, and probed C•WUG’s
experts looking for the most useful
ClarisWorks tips. Here are the ten most interesting
tips we encountered in our explorations.

I. Create your own default settings.

ClarisWorks gives you complete control over the
default fonts, margin settings, and other options
that appear when you create a new document. But
the procedure you follow to define your defaults is
not intuitive.

The trick is to create ClarisWorks stationery docu-
ments that contain your preferences. You create a

separate stationery document for each ClarisWorks
environment. Then you save the documents in
files named “ClarisWorks xx Options”; ClarisWorks
will use those files as the basis for every new docu-
ment you create.

The letters that replace the “xx” in the file name
tell ClarisWorks which file to use. For example, the
file “ClarisWorks WP Options” contains the default
settings for all new word processor documents.
“DB” defines the database defaults, “SS” controls
your spreadsheets, “DR” defines the drawing docu-
ment defaults, “PT” is for painting, and “CM” for
communications. You then store the default files in
the Claris folder within the System folder.

Try it. Follow these steps:

1. Create a new word processor document.

2. Switch to the font and size you want to use in
your future documents.

Special Sample Issue Page 3

General Interest

C•WUG’s Top Ten ClarisWorks Tips
by Warren Williams and Cathleen Merritt

Dr. Warren Williams, the President of C•WUG, is
a Professor Emeritus of Educational Technology
at Eastern Michigan University.

Cathleen Merritt, the Director of C•WUG, has
published more than 350 articles in the Claris-
Works Journal and in other computer newsletters
and magazines.

Figure 1: Simultaneous Layout and Browse Views

Windows



3. Change the margin and/or tab settings to your
new defaults.

4. Save the file as a ClarisWorks Stationery docu-
ment named “ClarisWorks WP Options” in the
Claris folder within your System folder.

5. Close the document. Respond “No” to the “Do
you want to save your changes?” prompt.

Now you will test your template. Create a new
word processor document and type a few charac-
ters. ClarisWorks should use the font you used in
your “ClarisWorks WP Options” document. 

II. Create two views of your database documents.

Changing a database layout requires you to switch
between Layout mode (where you change the lay-
out) and Browse mode (where you see the effects
of your changes). Repeatedly switching between
Layout and Browse modes can be tedious. 

To increase your efficiency, create two views of the
same data. Then you can display your document in
both modes simultaneously and immediately see
your changes on the screen (see Figure 1).

Follow these steps to create separate Layout and
Browse views of a database file:

1. Display the database in Browse mode.

ClarisWorks Journal
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2. Choose “New View” from the View Menu.
ClarisWorks will open a second window
with the same view of your document.

3. Choose “Layout” from the Layout Menu to
change the new view to Layout mode.

4. Choose “Tile Windows” from the View or
Window Menu. ClarisWorks will arrange
the windows so you can see both views on
the screen. Any changes you make in Lay-
out mode will immediately appear in the
Browse mode view.

III. Use the -(minus) keystroke to save
time entering database data.

Pressing -(minus) enters the current date,
time, or record number in date, time, and num-
ber fields respectively. That makes it easy to
enter dates and times in your database records.
(Windows users: Press Control-minus to enter

the date or time. A complete table of Windows
keystroke equivalents appears on page 10.)

IV. Use ClarisWorks’ Table Assistant to create
your tables and charts.

ClarisWorks’ word processor environment provides
tabbing tools that you can use to create tables and
charts. But ClarisWorks’ Table Assistant makes it
even easier to create lists and tables in your docu-
ments. For example, examine Figure 2which
depicts a word processor document that contains a
spreadsheet-based table with the formatted data.
You can then use ClarisWorks’ charting capabilities
to create graphs for your documents.

Try it. Create a word processor document and then
launch the assistant from the Balloon Help icon in
the top right-hand corner of your screen.

V. Use the “Copy Table” Command.

ClarisWorks for Macintosh’s communications envi-
ronment offers a Copy Table Command that auto-
matically copies and pastes tables from a communi-
cations document into a spreadsheet. That makes it
easy to copy financial information and other tabu-
lar data received from your on-line service into any
ClarisWorks document.

Figure 2: Using a Spreadsheet to Create a Table



Follow these steps to copy tabular data
captured from a bulletin board service
into a spreadsheet:

1. Click and drag to highlight the infor-
mation in the communications docu-
ment on your screen.

2. Choose “Copy Table” from the Edit
Menu.

3. Create a new spreadsheet or switch to
an existing spreadsheet template.

4. Click in the cell where you want the
first piece of tabular data to appear.

5. Choose “Paste” from the Edit Menu.
ClarisWorks will paste each piece of
data into a separate cell.

VI. Use ClarisWorks’ BEEP and
ALERT functions to improve your
spreadsheets and databases.

ClarisWorks’ BEEP and ALERT functions
let you warn users of mistakes they make
when using a ClarisWorks spreadsheet or
database template.

BEEP sounds the system beep; ALERT
sounds the beep and displays an alert 
box with the message you specify (see
Figure 3).

For example, the formula 

=IF(A10<0, ALERT("Illegal negative value in Cell
A10"),A3*A10)

displays a warning message if cell A10
contains a negative number. Otherwise,
this formula displays the product of cells A3 and
A10. 

VII. Use ClarisWorks’ Lock Titles Option to
lock titles on your spreadsheet screen.

ClarisWorks lets you lock the top rows and the left-
hand columns of your spreadsheet templates as
“titles” on the screen. The titles stay on the screen
when you scroll around a large worksheet; that
makes it easier to read the column and row head-
ings in your template.

ClarisWorks Journal
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To lock the titles, put the cursor on the cell that
defines the lowest row and right-most column that
contains the titles. Then select “Lock Title Posi-
tion” from ClarisWorks’ Options Menu (see Fig-
ure 4).

You cannot edit locked titles. To unlock the titles,
re-select “Lock Title Position” from the Options
Menu. 
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Figure 3: Warning Message Generated by the ALERT Function

Figure 4: Spreadsheet with Titles
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VIII. Use the NOW function to enter the cur-
rent date or time in a spreadsheet cell or a
database record.

ClarisWorks’ NOW function displays the current
date or time in a spreadsheet cell or database
record.

In a spreadsheet, enter =NOW() as the formula and
set the number format of the cell to display a date
or time. In the database environment, define the
field as a calculated field, enter the formula NOW(),
and select “Date” or “Time” from the “Format
result as...” pull-down menu.

IX. Use text and graphic frames for your notes.

ClarisWorks lets you create text and graphic frames
to present instructions and notes. For example,
examine Figure 5 which uses a graphic frame in a
spreadsheet to display instructions for the template.

To annotate a cell, select the Text Tool and click
and drag to create a text frame next to the infor-
mation you want to annotate. Then enter the text
you want in the note. You can leave the text frame
selected when you save your template and tell the
readers to delete the frame by pressing the Delete
Key after they read the note.

You can also use ClarisWorks’ graphic tools to
create an attractive border around the message
like the example in Figure 5. Follow these
steps:

1. Select the Rectangle Tool. Then click 
and drag in the spreadsheet to create a
rectangle. Drag the rectangle into its final
position in the spreadsheet.

2. Select a fill pattern from the Fill Palette.

3. Select the Text Tool and click within the
rectangle.

4. Select a font, font style, and font size from
the Font, Size, and Style Menus. Then type
the text you want in your label. 

5. Select the Arrow Tool. Then click once on
the text and re-size and re-position the text
block within the graphic.

X. Use the tear-off fill and pen tool palettes.

ClarisWorks offers “tear-off” fill and pen tool
palettes that you can put anywhere on your screen.
To save time and effort, put the palettes next to
the objects you are creating or modifying. The
torn-off palettes remain open until you click on
their Close Boxes.

To tear off a palette, click on the tool to open the
palette and drag to the right until the palette
moves away from the left edge of the screen. 

Conclusion

These are just ten of the dozens of tips and sugges-
tions we receive from our C•WUG colleagues.
Collecting and sharing your ideas is one of our
most important jobs; please send your ClarisWorks
tips to “My Favorite Tip”, C•WUG, Box 701010,
Plymouth, Michigan 48170 or fax your ideas and
suggestions to (313) 454-1965. ■

Figure 5: Using Text and Graphics Frames



Growing numbers of small business owners use
ClarisWorks to prepare their correspondence
and manage their finances. And many users

are discovering that ClarisWorks is also flexible
and powerful enough to handle their company’s
advertising and promotions.

Brochures are a perfect way to promote your busi-
ness; a well-designed brochure can evoke a gratify-
ing response from existing and potential cus-
tomers. You can display your brochure at the front
desk or checkout counter, or you can create a
brochure that you mail to customers. Either way, a
tri-fold flyer provides an opportunity to highlight
your company’s products or services.

This article describes how to create a ClarisWorks
template you can customize to create your own
two-sided, tri-fold brochure like the example in
Figure 1.

Since there are as many brochure styles as there
are ClarisWorks users, you should feel free to copy
or “tweak” this layout to suit your taste. The infor-
mal look I chose is appropriate for a fictitious lawn
service such as Keep It Green, but my design is
equally at home in a consignment shop or bed and
breakfast inn. By contrast, a law office might want
to project a more formal image.

The paper you use can enhance your message, so
you should choose your paper carefully. Solid color
paper is a low-cost alternative, but designer papers
like those offered by the suppliers listed in the
“Colorful Options” sidebar can make your cus-
tomers sit up and take notice. And that is what
this template is all about.

Creating the Brochure Template

Follow these steps to create your own tri-fold
brochure:

ClarisWorks Journal

1. Launch ClarisWorks and begin a new drawing
document.

2. Choose “Page Setup” from the File Menu and
select the landscape page orientation.

3. Select “Page View” from the View Menu for a
more WYSIWYG (what you see is what you
get) look at your work-in-progress.

4. Choose “Document” from the Format Menu
and set all the margins to zero inches. (All
measurements in this template are in inches.)
That lets you divide each page into three bal-
anced columns. Set “Pages Across” to “2” and
click on “OK”.

5. Select “Rulers” from the Format Menu, click on
the Graphics Button, and set the ruler divisions
to “16”. Although ClarisWorks will divide the
rulers on the screen into eighth-inch increments,
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My Favorite Template

Nanette Luoma is the former Graphic Designer,
Page Layout Specialist, and Public Domain
Librarian for the ClarisWorks Users Group.

How to Create a Tri-fold Brochure
by Nanette Luoma

Windows

Figure 1: A Tri-fold Brochure 



ClarisWorks’ Autogrid feature will accommodate
precision to one-sixteenth-of-an-inch when you
lay out your brochure. Then click on “OK”.

Now you will draw vertical lines to serve as guides
for the layout on each page. The settings I suggest
leave room for the folds between the pages. Con-
tinue as follows:

ClarisWorks Journal
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6. Double-click on the line tool to
“permanently” select that tool.
(Double-clicking on the tool lets
you create all four lines without
jumping back to the Tool Palette.
Clicking on any other tool turns
off the line tool selection.)

7. Draw lines down the page starting
at the following points on the
ruler at the top of the screen:

• 3 5/8-inches
• 7 5/16-inches
• 14 11/16-inches
• 18 3/8-inches

To draw straight lines, click on the
starting point of the line, then hold down the Shift
Key to “constrain” ClarisWorks while you draw the
line. (“Constraining” makes the line perfectly
straight.)

8. Press -A to select all the lines and -G to
group them as a unit. Grouping the lines makes
it easier to delete them before you print your
finished brochure. Click anywhere on the page
to de-select the temporary guides.

9. Select “Frame Links” from the Options Menu.
This displays the text frames you will create in
the next step and makes it easier to select the
correct frame.

Now you will draw the text frames for your tem-
plate. Continue as follows:

10.Double-click on the text tool and draw the fol-
lowing text frames. Begin each frame one-half
inch from the top of the appropriate page and
end each frame at the 8-inch mark near the
bottom.

Left Edge Right Edge
Text Frame Begins at: Ends at:

Panel 1 .1/4 3.1/2
Panel 2 3 3/4 7.3/16
Panel 3 7.7/16 10.3/4
Panel 4 11.1/4 14.9/16
Panel 5 14.13/16 18.1/4
Panel 6 18.1/2 21.3/4

Figure 2: Brochure with Text Frames

Colorful Options
Here are five sources of attractive colored papers that
can enhance your flyers. Call the companies’ toll-free
numbers to request free, full-color catalogs. Designer
paper is pricey but, to paraphrase an old saying, “Using
the best paper for your brochure doesn’t cost, it pays.”

IdeaArt
Box 291505
Nashville, TN 37229
(800) 433-2278
(800) 435-2278 (fax)

Paper Access
23 West 18th Street
New York, NY 10011
(800) PAPER-01
(212) 463-7022 (fax)

PaperDirect
205 Chubb Avenue
Lyndhurst, NJ 07071
(800) A-PAPERS
(201) 507-5488
(201) 507-0817 (fax)

Queblo
1000 Florida Avenue
Hagerstown, MD 21741
(800) 523-9080
(800) 55-HURRY (fax)

Quill
Box 94080
Palatine, IL  60094
(800) 789-0057
(800) 789-8955 (fax)
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Figure 3A: Page One of Brochure

Figure 3B: Page Two of Brochure
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— Spring —

• Get a head start on a green lawn with our early
fertilizer application.  It gives your yard a
strong beginning and helps build a good root
system.

• We repair any damage from the previous win-
ter. Your yard will be ready to display with
pride.

• We provide you with a never-ending series of
bright flowering plants. We unobtrusively
maintain and replace flowers. You’re guaran-
teed constant color to highlight your buildings.

• Raking, hoeing, seeding, sodding – no matter
what your lawn needs to make it healthy, we
do it all.

— Summer —

• Our feeding program keeps your lawn looking
healthy all summer long.

• We keep your lawn free of weeds. Your yard
will remain smooth and emerald green
throughout the season.

• Summer storms can wreak havoc with your
yard. Our maintenance crew prunes damaged
trees and removes fallen branches.

• Bug, bugs, bugs! Summer is full of them. From
giant caterpillars to gypsy moths, we help you
keep ahead of them.

— Fall —

• Fall is the time to get your lawn ready for the
next summer. We feed, de-thatch, and mulch
your lawn to keep it looking its best next year.

• The beautifully colored leaves of autumn are
wonderful...until they fall off the trees. But with
Keep It Green, there’s no hassle. We rake, bag,
and remove the leaves before you even realize
they’ve fallen.

• Plants which bloom beautifully all spring and
summer can’t always survive winter on their
own. We protect your plants to help ensure they
look just as lovely next spring as they do now.

— Winter —

• Winter brings its own problems. Among other
services which we provide, we shovel snow
before your business opens for the day.

• Winter storms with their ice and heavy snow
can harm your trees. We take care of damaged
trees and remove fallen branches.

• We use salt and gravel to make sidewalks safe,
no matter how harsh the weather.

with

Keep It Green

you can have
…a beautiful yard…

without lifting a finger
or 

straining your budget

n Yes! I want a FREE appraisal. Please
contact me to arrange an appointment.

__________________________________
Name

__________________________________
Address

__________________________________

__________________________________
City, State, Zip Code

__________________________________
Telephone

Keep It Green
Four seasons yard care
1234 S. Maple
Calumet, MI  49913
(906) 555-1212

Section headers are set in Optima, 12 point, Bold, centered. Press Shift-Option--
to type the em dashes . The body text is Palatino, 10 point. The bullets are pro-
duced by pressing Option-8 followed by a tab.

Palatino, 14 point, Bold, centered.

Optima, 14 point, centered.

Create the check box by using
the letter “n”, set in Zapf Ding-
bats, Outline.

Produce the “underline” by pressing
Shift-- repeatedly.  The fine print
below the line is 7 point Palatino.
Make the entire line (including the
Return) 7 point to ensure that the
spacing is correct.

“Keep it Green” is set in Palatino, 22 point, Bold
Italic. The address is set in Palatino, 12 point.
Then rotate the text block 90° counter-clockwise.

Optima, Bold
36 point, centered.

“Falling Leaves” EPS format clip
art, available on C•WUG’s
Graphics Primer Disk.

Optima, Bold
36 point, centered.

Press Option-; to type the ellipsis
(…). To make this line appear
balanced, type “…Lawn…”,
select the first ellipsis, and
change the text color to white. 
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Your layout should look like the example in
Figure 2.

11.Follow these steps to add your return address to
the mailing panel:

A. Select the text tool and draw a small text
frame in the middle panel of the first page.

B. Type and format your return address infor-
mation.

C. Click on the the arrow tool and select the
text frame. Then choose “Transform” from
the Arrange Menu and select “Rotate”.
Select “Rotate” two more times to orient
the return address block properly.

12.Save your template in a ClarisWorks stationery
file named “Brochure Template”. Then close
the document.

Using the Template

Follow these steps to use the template:

1. Open the stationery template to create a new
document and create a brochure to suit your
needs. The possibilities are beyond the scope of
this article, but you can can get some ideas
from the example in Figures 3A and 3B.

2. When you are done, select one of the tempo-
rary guides and press -X to delete all four
lines. Then save your design.

Now you will print the brochure. Continue as fol-
lows:

3. If you use a LaserWriter, select “Page Setup”
from the File Menu and choose “Larger Print
Area (fewer downloadable fonts)” from the
LaserWriter Setup Menu.

4. Select “Print” from the File Menu (or press 
-P). ClarisWorks will warn you that the doc-

ument’s margins are too small and may cause
the printout to be clipped. Ignore the warning
by clicking on “OK”. Then print your work.

5. Examine the edges of each page carefully for
missing text or graphics. See the sidebar enti-
tled “How to Handle Printing Problems” if your
output is not acceptable.

Conclusion

As you can see, it is easy to prepare your own tri-
fold brochures with ClarisWorks. Simply print a
master copy and then take it to a local quick print-
er for double-sided copying. Fold the brochures,
attach mailing labels, and send your promotional
piece on its way. ■

How to Handle Printing Problems

Some printers do not print closer than .42 inches
from the edge of the page. If your printer clips the
edges of your document, use the following margins
in step #10:

Left Edge Right Edge
Text Frame Begins at: Ends at:

Panel 1 .1/2 3.1/2
Panel 2 3.7/8 7.3/16
Panel 3 7.9/16 10.1/2
Panel 4 11.1/2 14.1/2
Panel 5 14.7/8 18.3/16
Panel 6 18.9/16 21.1/2

Keyboard Reminders

C•WUG uses Macintosh keyboard conventions in
the ClarisWorks Journal. Windows users should sub-
stitute the following keystrokes when completing the
tutorials in each issue:

Mac Windows

Press the Control Key (or Ctrl Key). For
example, press Control-S when an author
says “Press -S”.

Option Press and hold down the Alt Key when an
author tells you to use the Option Key.

Return Press the Return, Enter, ←, or ↵ key on
the keyboard when asked to “Press the
Return Key”. (Windows keyboards label
this key differently.) Do not press the
Enter Key on the numeric keypad unless
specifically instructed to do so.

Windows
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Database Primer

This article describes how to create and
print database reports. You will need the
coin collection database included on the
C•WUG’s Best Templates disk that accom-
panies this issue.

Much of your work with database files
can be classified as “overhead”; oper-
ations you must perform if you want

to store your data on a computer. Necessary
“overhead” includes creating the database
and entering and maintaining your data. Of
course, all that work pays off when you view
or print your records.

ClarisWorks gives you three ways to use your
data: (1) You can view the contents of one
or more records on your screen, (2) You can use
the program’s mail merge capability to combine
information from your database into any string of
text, and (3) You can print reports that list or sum-
marize the information in your file.

This article describes the reporting process. By the
time you complete this tutorial, you will be able to
create and print ClarisWorks database reports.

You need a database for this project. Rather than
having you create one from scratch, I created the
file for you. It’s the coin collection database on the
disk that Claris shipped along with this issue. [Ed:
The author selected a coin collection example
because it requires calculated and summary fields.
That will help you develop the skills you need to
work with different types of database files.]Your
final report will list the contents of each coin col-
lection case (see Figure 1).

Four Stages

Producing a report is a four stage process:

Stage I: Create a layout.

Stage II: Select the records for the report.

Stage III: Sort the data.

Stage IV: Save the report.

It’s easy to remember the sequence of these opera-
tions because they follow the order of the four but-
tons on ClarisWorks’ database Tool Palette (see
Figure 2).

This tutorial will take you step-by-step through the
reporting process. I suggest that you launch Claris-
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Figure 1: Coin Case Directory Report 

Figure 2: Database Tool Palette
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Works, open the “Coin Collection.DB” data-
base on the accompanying disk, and work
along with this tutorial. (Windows users:
Open the file “COINS.CWK”.)

Stage I: Creating the Layout

You will start by creating the layout for the
Coin Case Directory report in Figure 1. Fol-
low these steps:

1. Click on the Layout Button on the Tool
Palette and select “New Layout” (see
Figure 3).

2. With the New Layout Dialog Box on the
screen, select “Columnar Report”. Name
the layout “Coin Case Directory”, and
click on “OK” (see Figure 4). Claris-
Works will display the Set Field Order
Window (see Figure 5).

Now you will choose the fields you want to
print in the report and the order they will
appear across the top of the page.

3. Click on the Coin Case # field name in
the Field List, then click on “Move” to
put that field in the Field Order Window.

4. Repeat this process for the Coin Type,
Year/Mint, Condition, and Count fields.
Then click on “OK”. The columnar lay-
out that appears will look like the exam-
ple in Figure 6. 

5. Select “Layout” from the Layout Menu.
Your screen will look like the example in
Figure 7. The field names appear as
labels in the Header Section at the top
of the page. The Body Section shows
where ClarisWorks will print each row of
data.

Now you will use the Arrow Tool to adjust
the size and location of the fields and field
labels.

6. Click on the Coin Case # field (not the
field label) to select that field. “Handles”
will appear at the corners of the field
box.

Figure 3: Creating a New Layout

Figure 4: New Layout Dialog Box

Figure 5: Selecting Fields for the Report 

Figure 6: Unenhanced Columnar Layout 
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7. Click on the lower-right handle, hold
down the mouse button, and drag the
mouse to the left to reduce the size of
the box. Re-size the field so it looks like
the example in Figure 7.

8. Next, you will re-position the Coin Type
field and its associated label. Click in the
center of the Coin Type field, then hold
down the Shift Key and click on the
Coin Type label in the Header Section at
the top of the screen. That selects both
the field and the associated label.

Release the Shift Key and the mouse
button. Then press the Left Arrow Key
eight times to move both objects into
the position shown in Figure 7. Then
click elsewhere on the layout to de-
select these objects.

9. Re-size the Coin Type field by clicking
and dragging the lower-right handle to the
right.

10.Re-size and re-position the remaining fields and
labels so your screen looks like the example in
Figure 7. Owners of small monitors will have to
scroll to the right to re-size and move the
Count field and its associated label.

11.Select Browse Mode (Shift- -B) and check
that you allocated enough space to each field
and to the space between the rows of data.

12.If your layout does not display all the data,
press Shift- -L to return to the Layout Mode,
and modify the layout. Then repeat step #11.
The space between the row of fields and the
Body Line determines the amount of space
between the rows of data in your report. You
can adjust this space by moving the Body Box
up or down on the layout. Experiment with
different settings. Press Shift- -B to display
the results of your changes and Shift- -L to
return to Layout Mode.

Adding Summaries

Now you will add a “Sub-Summary” section to
your layout. This summary will count and report
the number of coins in each coin book or case. 

1. Go to the Layout Menu and select “Layout” (or
press Shift- -L). Then select “Insert Part”
from the Layout Menu.

2. ClarisWorks selects “Sub-Summary when sorted
by…”. Click on “Coin Case #” and click on
“OK” (see Figure 8). That tells ClarisWorks to
print a sub-summary section each time it
switches to the next coin case number.

3. Sub-Summary sections can appear above or
below the body of the report. Click on “Below”.
The layout will re-appear with the Sub-Sum-
mary section below the Body section.

Figure 7: Fields Re-Sized and Re-Positioned

Figure 8: Insert Part Dialog Box 

Field Label

Figure 9: Adding the “Total Count” Summary Field
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Next, you will insert the Total Count summary
field that will display the total number of coins in
each coin case.

4. Go to the Layout Menu and select “Insert
Field”.

5. Select “Total Count” from the Insert Field
Window and click on “Insert” (see Figure 9).
The Total Count field and its associated label
will appear in the body of the layout.

6. Select both the Total Count field and field label
by holding down the Shift Key as you click on
the field and its associated label. Then release
the Shift Key, click on either the Total Count
field or its label, and re-position the two objects
in the Sub-Summary area (see Figure 10). [Ed:
You can also use the Arrow Keys to move the
objects into their final positions.]

7. Click and drag the Body Line to adjust the
spacing so it matches Figure 10.

8. Select Browse Mode (Shift- -B) to see the
effects of your changes. [Ed: The Total Count
field will not appear on your screen until you
sort your data in Stage III below.] If necessary,
return to Layout Mode (Shift- -L) and adjust
your layout. 
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9. That completes the report layout. Press
-S to save your work.

Stage II: Selecting Records

Your next task is to select the records for
your report. Your sample report will include
all the records in the file, so you will not
enter record selection criteria in this tutori-
al. But here are the steps to follow when
you select records for other reports [Ed: See
the article entitled “How to Locate Specific
Records” in the December 1993 issue of the
ClarisWorks Journalfor help using Claris-
Works’ Find Command.]

1. Click on the Select Records Button on
the Tool Palette and choose “New
Search” (see Figure 11).

2. Enter a name such as “Pennies” for the
search. Enter a search name that will help
you remember the selection criteria estab-

lished for that search.

3. Click on the field(s) you want to include in the
search and enter the search criteria. Then click
on “Store”.

4. Click on the Select Records Button and select
the search name from the pop-up menu. Claris-
Works will select the records you specified in step
#3 above. Select “Show All Records” from the
Organize Menu to display all the data in your file.

Stage III: Defining a Sort

Next, you will define the rules you will use to sort
the records in the report. You want your Coin Case
Directory to list the records by Coin Case #. Then,
within each case, you want to list the coins by Coin
Type, and finally, within each Coin Type, by
Year/Mint (see Figure 1).

Follow these steps to define the sort:

1. Press Shift- -B to enter Browse Mode.

2. Click on the Sort Records Button on the Tool
Palette and choose “New Sort”. ClarisWorks
will display the Sort Records Dialog Box in
Figure 12.

Figure 10: Sub-Summary Area and Summary Field in Place

Figure 11: Defining a Search



Now you can print the report. Just click on the
Report Button on the Tool Palette and select
“Coin Case Directory”. ClarisWorks will switch to
the correct layout, sort your data, and print the
report.

Conclusion

Well, you’ve done it. You created your first report.
As you saw, the process involves more than two
dozen steps, but each step is easily “do-able”. And
the overall process flows in a logical, sequential
order guided by the four buttons on ClarisWorks’
database Tool Palette.

Since ClarisWorks saves your report specifications,
printing each report is as simple as selecting the
saved report from the database Tool Palette. ■
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3. Name the sort “Coin Case Directory”. 

4. Select “Coin Case #” in the left window
and click on the Move Button. The
default sorting order is “ascending”, and
since you want the coin cases listed in
ascending order (that is, from 1 to 10),
accept this ClarisWorks default. 

5. Select “Coin Type” and click on the
Move Button. Then select “Year/Mint”
and click on “Move”. Once again,
ascending order is appropriate. Your
screen should look like the example in
Figure 12.

6. Click on “OK” to define the sort.

7. Now you will sort the data. Click on the Sort
Records Button and select “Coin Case Direc-
tory” from the menu. ClarisWorks will sort the
coins by their case number, by coin type, and
then by year minted within each coin type.

8. Now you can see the effects of your changes.
Press Shift- -P (or select “Page View” from
the View or Windows Menu) to display the
report in Figure 1.

9. Press -S to save your work.

Stage IV: Saving the Report

Finally, you will save the report layout, search, and
sort criteria so you can print the report with a sin-
gle mouse-click. Follow these steps to save your
report format:

1. Click on the Report Button on the Tool Palette
and choose “New Report” (see Figure 13).

2. Name the report “Coin Case Directory”. 

3. Select “Coin Case Directory” from the Layout
pop-up menu.

4. Select “Coin Case Directory” from the Sort
pop-up menu.

5. Click on “Print Report”. That tells ClarisWorks
you will want to print the report instead of just
viewing the results on the screen.

6. Click on “OK” to save the settings.
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Figure 12: Sort Records Dialog Box

Figure 13: New Report Dialog Box
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5. Use ClarisWorks’ NOW function to automatically
enter today’s date in a spreadsheet cell or a database
record. (page 6)

Graphics Tips

1. For easier formatting, “tear off” the Fill and Pen Palettes
when you need to modify a graphic object. (page 6)

2. Use Page View to help you visualize a heavily format-
ted document. (page 7)

3. Double-clicking on a tool lets you create multiple
objects with the tool without returning to the Tool
Palette. (page 8)

4. Try drawing vertical lines to help you visualize the
panels on your layouts. (page 8)

5. For perfectly straight lines, hold down the Shift Key
when you draw the line. (page 8)

6. Tri-fold brochures require unequal-size panels. (page 8)
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